Linux Flatpak?

Hello Aspect team!

First let me say I just installed Aspect and I’m loving it, it’s a breath of fresh air.

I’m considering buying it but I have a few questions first.

  1. I’m using Aspect on Linux and would like to know if the final version for Linux will be released at the same time as Windows and Mac final version?

  2. Will you be releasing the application as a flatpak as well? AppImage is not very stable at the moment and doesn’t work out of the box on new Linux distributions because libfuse2 is deprecated and not installed by default anymore (I get some errors related to something called “FUSE” — AppImage documentation)

Thank you!


We generally have to prioritize the other platforms, unfortunately, so I can’t make any promises (there really is just a single occasional Linux user that we know of). The Linux version will probably keep its “experimental” status when 1.0.0 is ready, because there are quite a few corners that would need some polishing to call it a proper release, but I really hope to have at least drag’n’drop support implemented and I can look into the distribution format as well.

So right now I’m testing the release on Linux Mint 21/Ubuntu 22.04 and it works for me there, but maybe that’s just because I’ve upgraded from older versions before. There currently is an open PR to fix this in AppImage so hopefully we can have the image fixed soon.

But although I’m personally not really a fan of Flatpak (or Snap), as long as the creation is relatively simple, that’s definitely an option that we can look into.

Thank you Sönke for your quick reply. I appreciate your honesty.

I tried running the Aspect AppImage on a new install of ubuntu 22.04 in a VM:

$ ./aspect-1.0.0-preview.27-x86_64.AppImage 
dlopen(): error loading

AppImages require FUSE to run. 
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
for more information

It worked in Fedora 37 but it didn’t work on Fedora 37 Silverblue. You can install fuse2 and get it to work but it’s an additional step.

The AppImage for 1.0.0-preview.29 is now built using a static AppImage runtime. I didn’t get the chance to test it on a FUSE 3 based distro, yet, but in theory it should work now without libfuse2 being available.

We’ve also looked into Flatpak, but had to postpone that, as setting up the build environment proved to be quite a bit more involved than it first seemed. But we’ll revisit that at a later point.

Thank you for your work and for looking into flatpak.