Linux image import broken

Observed behavior

Import images is not working. It didn’t transfer even one photos (15MB) in more than 30 minutes.
It created one image file DSC01150.JPG.tmp but didn’t complete the transfer of it in 1 hour.

Expected behavior

Quickly import photos and movies.

Steps required to reproduce

After starting “import photos” it showed all the image and movie previews quickly (great improvement).
The application showed two processes running:

  • importing files
  • Synchronizing file system…

The SD card in the camera (Sony ZV-E10) was formated recently and had only 71 photos/movies on it (1.2 GB)

I connected the camera to the computer via USB-C which shows the SD card as a mounted volume from which I import photos.

Copying files with a file manager took less than 10 seconds.

Operating system/Hardware used

Ubuntu 22.04,

After trying a few different things, I haven’t been able to reproduce the issue. What I have tried so far:

  • Import some photos on a Linux Mint 21.2 system (Ubuntu 22.04 base)
  • Use the Sony ZV-E10 test SD card folder to import from
  • Do the same on an original and freshly installed Ubuntu 22.04.3 and from a mounted USB stick

But then the fact that “synchronizing file system” was also running got me thinking that maybe the issue is in fact not the import itself, but the synchronization process that hangs for some reason, in turn blocking the import from finishing. So the question then would be whether after starting the application and not importing anything, does the “synchronizing with file system” ever disappear? If not, can you send me the /tmp/aspect-log.sdl via direct message or mail? Maybe there is a hint contained for where it stumbles.

In case the synchronization does finish, however, and the issue is actually in the import process, to narrow down the cause, can you try to verify whether this occurs

  1. for every import and not just occasionally
  2. only when importing from the camera directly, or also when importing the same files from somewhere else

I started the app again today. And since the “Synchronizing file system” was still running when I closed the application I got a crash report window.

After that I got a window I haven’t seen before: A shoebox from a different version of this library was found…

I upgraded the application from preview.27 to preview.28 and now to preview.29 and I haven’t seen the window above before.

After this window I was able to import my images without a problem and it also worked fast.

Now the “Synchronizing file system” process finished very quickly which was a problem for me before. It must have been some kind of race condition that blocked the proper execution of the import.

I sent the crash report when asked so you should be able to look into the logs if needed.

Thank you for your help.