First start

Hi all and thanks Fischkoeppe,

Collected first start thoughts:

Windows 10, Aspect 1.0.0-preview.2

  • Download / install
    I wrote the link to the download without https, which is a 404.
    Firefox marked the exe as ‘unusual file’, wanted to delete it again.
    Windows Defender SmartScreen protected the file, blocked execution.

  • App start, used license.txt
    I had called the license.txt differently, the license picker couldn’t pick a different file name.
    No example library possible, created my own.

  • Library creation dialog
    Nice visualization, this works well.

–> HD4600 has render issues (flickering in dialog, no rendered image in main screen, see also log)
I restarted after switching to a Geforce card, which works

  • Library creation
    “Import” button above items is small, but when you look, you find it.
    I realized I didn’t like the library setup, wanted to change the layout, which can’t be changed in the settings, went for creating a new library. When I selected my D: drive to import photos from, the main screen didn’t show anything anymore. (log 2nd library failed).

–> Restarted

  • Library creation
    For folder navigation, the tiled based layout isn’t too great, as its either gigantic folders and readable / not chopped text or the text is chopped.
    Having import at the top of the screen feels strange at first. I would have expected actions like this to be at the bottom of the screen, although its not a dialog.

  • Import button
    I already have a custom library setup I wanted to import and copy over to the Aspect lib.
    I start small, don’t want to import my full lib. If I select some folders, this is confusing:

  • Fotos importieren : I understand this as: those are the once I selected, which will be imported
  • Aktuellen Ordner als Ereignis importieren: Is this the currently viewed or the selected?
  • Unterordner … : Dito as above, is this about the subfolders of the selected or the currently viewed?
  • Import dialog
    I hesitate to use the import button, as I expected this to start an operation immediately. But there is another step before this is actually done. That import dialog (or how such UI element is called) can have a lenghty idle spinner, which could use an explanation and ideally a progress estimation (what do I wait upon, do I have to wait? afaict this where about 30k photos).
    The checkbox “Kopien am Quellort belassen” could use some more explanation. Does this delete if unchecked? SD import might be more relevant for this, but I’m currently importing from my existing lib, which I don’t want to change / modify.
    … After waiting some minutes: Yes, I guess I have to wait before I can hit “Import”. Do I now will have to wait twice? Once on import selection and another time the actual import?

… After several minutes, which I didn’t stop as I did something else
Scrolling is well, but photos take half a minute or more to appear. Plain selection feedback on these photos is close to one second, which is quite long.

I wonder: How do I import my old lib? In one rush and organize afterwards or re-use my previous events to create events on import?

While doing that, I scroll click here and there. Then try to drag-select-box a bunch of (still not visible / black) photos. This looks to be a drag operation. I do it a couple of times, one time the main menu opens, although the cursor was afaict not in the vicinity, then I continued doing random drags, then a crash (no “this has stopped” warning, simply the app closed).

–> lib creation, then crash.log

Restarted, I get a dialog:
“Eine Fotobox aus einer anderen Version dieser Bibliothek wurde gefunden”
This dialog seems to be missing some string (snippet >>…Version der geoeffneten Bibliothek “” wurde gefunden <<)
What does that dialgo mean? So far, I didnt’ import anything and even if so, what are versions of libraries? But since this was “succesfully integrated”, I didn’t bother too much atm.

Instead of the import down left, I used Menu -> existing events with multiple sub-folders.

This dialog looks like the import I need. As this is a huge list where I wanted only a couple of folders, I click-selected and wanted to select by space and cursor navigation. Space however accept the import dialog and moved on with that. A question on how to treat RAW/JPG I used to abort import.

I restart that dialog.

Shift-click selection of multiple folders isn’t possible. I have about 100 folders to select, so this is a not great. Also, toggling between “Move” or “Keep” somehow re-builds the UI visually and is only execute after a delay (?). So I will only import a couple of folders. No, actually screw that, I’ll import the root of those folders and see what will happen. Though, I didn’t close the privous import dialog and now there are two on top. The “back arrow” next to the search bar has no effect.

Using my photos containing root folder, the import folder tree widget switches UI layout while operating on it, this feels quite weird. (Sorry, no video of this). Sadly, it doesn’t look like my plan works, so I select a couple of photos. A bit annoying is the UI update after selection of a folder, which changes the layout when populating tha amount of photos in a folder.

That’s it for today, I close Aspect.

General UI feedback:

  • Black main screen
    Related to HD4600, I’ll send the log.

  • Text entry fields don’t support wordwise selection / wordwise cursor navigation.
    Should place the cursor at the start/end of the current word when using CTRL+cursor.

  • Text entry fields don’t allow selection by mouse
    Should sellect words (double click), whole field (triple click)

  • UI flickers on text entry (eg create library screen)* This was with intel HD 4600
    In case you don’t know this, I can share a screen capture.

Thanks for the detailed first use log! I’ll add tracking numbers for the issues and will look into the AMD rendering issues. The text field selection already has an issue number, as far as I remember.

Starting with the next version, license files will be called “aspect.lic” and any “*.lic” files will be recognized, too, so this can be regarded as fixed.

The multi-folder import also has already been revamped to match the actual drafts and to actually work as intended (will be available in the next version). Efficient keyboard interaction is left for a later version, though - the current development version now forbids selecting lines at all until this is properly implemented.

Scrolling is well, but photos take half a minute or more to appear. Plain selection feedback on these photos is close to one second, which is quite long.

A few questions to pinpoint the issue:

  • Was this just happening right after the import (i.e. while the import activity was still running), or is it still this slow now?
  • Did “Analyzing images…” possibly still run (also displayed in the bottom-right corner of the window)?
  • How many megapixels/megabytes do the photos usually have?
  • Did the selection delay happen in the import dialog, or in the library (Fotostream) after initiating the import?

Though, I didn’t close the privous import dialog and now there are two on top.

Do you remember how you were able to open two dialogs/sheets at once? If everything works correctly, they should actually be fully modal, except for the window’s minimize/maximize/close buttons.

I’ll come back to the remaining UX issues and will post the internal references for the remaining issues. Thanks again for taking the time to write this down!

Sorry for the delay, the notification went to the spam folder.

I sadly don’t recall the details on the slow import screen, but this was before importing.

Photos: about 10MP, 3MB, mostly from omd em-1, see raws but majority is jpg. Rarely a video

For the two modal windows also no reproduction.

Okay, I tried with a large folder (60k files) and got the same issue, will be fixed in the next version!

I could also reproduce the issue with images appearing late. This is tracked as #445 for now.

Continuing with the updated binary [1.0.0-preview.3]

I have only some limited amount of time today, hence I didn’t try many workarounds / other solutions.

tldr: I can’t import

Byg using bottom left file navigator: “Import” button is grayed out in the folders I’m interested in

  • Witth bottom left file navigator, navigate to d:\drive\ (google drive mirror folder)
  • “Import” button is enabled
  • Navigate to d:\drive\photos, button is deactivated
  • Navigate to d:\drive\photos\2016 - 06 - Some event, still deactivated :confused:
  • Navigate to d:\drive\ button is enabled

Bug: Import screen modal window behavior

  • Using ‘File’ -> Import, import a dedicated folder
  • “Back button” above import screen is still activated and navigates the main page, which is hovewer corectly disabled / modal window like

Bug: Import screen, shows no images

  • Using ‘File’ -> Import, import a dedicated folder
  • Shows 0 images, but that folder contains actually 735 images
    Might be related to the first issue. But navigating using the bottom left file navigator shows those 753 images (But that import button is grayed out).

I’ve sent over a logs file. (…noimport)

The reason is (presumably) that those folders are already part of a library, either the one currently open, or a different one. Importing is only possible for normal folders. If this is from an old library that doesn’t exist anymore, you could delete all event.sdl files from the “photos” sub folders and it should work again.

Would be interesting to find a good way to better (or at all) communicate this in the UI.

This is interesting, it’s supposed to be fixed in this version and I haven’t been able to reproduce it. How did you open the import dialog, and is the menu button and search bar also enabled?

Edit: scratch that, I missed the first bullet point and it actually perfectly reproduces that way for me.

Are the images in the folder directly, or in a sub folder? In the latter case I’d second that it’s the same cause as for the first issue.

Thanks for the quick update!

The reason is […] could delete all event.sdl files from the “photos” sub folders and it should work again.

I’m impressed. The filewatcher is damn responsive and somehow you’ve prepared for folks renaming / deleting event.sdl files in folders in the file browser screen. Renaming to event.sdl.old immediately enabled the import button.

Note to self for next import: Get-ChildItem -Filter event.sdl* -Recurse | ForEach-Object -Process { del $_.FullName }

Would be interesting to find a good way to better (or at all) communicate this in the UI.

Ways you have probably already thought about:

  • Markers on folder icons while navigating them with the file browser
  • Alwasys activated import button, with informative text in the popup, once clicked in a library folder

Are the images in the folder directly, or in a sub folder?

I think I realized my mistake only today: I’ve tried to created several events from subfolders, but actually pointed to a single event, in which case that is not how it was ment. … … But I thought I have seen a text like “0 Photos” instead of what I see today “0 events”.

Anyway … continuing with a [New import]

Confusing import error message: “Ereignisse muessen…”
Importing the same folder as in #5 (735 images), I get an error message. Interpretation:

“The image files I want to import (from Drive D:) should better be in Drive D:, as else it won’t work.”
“The other solution is to use a library on C:”
grafik

Confusing too: Library setting:
grafik

… on second thought. These later error might be due to me deleting .sdl files…

I’ve restarted.

  1. Created a new library.
  2. Went for import, realized I created a library structure with days, but I just want months
  3. Created a new liubrary -> silent crash / shutdown (sent over aspect-log-preview3-crash-create-2nd-lib) (the file browser was opened, in case that matters)

I’ve restarted

Using the file browser, I navigate to the drive folder, select a handful of events I woul’d like to import.

  • Automatic event creation is nice, but for things like my folders, eg “2001 - 04 - Odyssey zum Geheimsee” it creates “- Odyssey zum Geheimsee” (leading dash)
  • After changing from “- Odyssey …” to “Odyssey …”, I can’t use tab to navigate to the next event’s input box.
  • For multi - month photos, there may be a different opinion: I think I used the start of the series, not the end (eg for “2001 - 04 - Odyssey…” is actually “Library/2001/05 - Odyssey…”
  • … While changing the names a crash. aspect-log-preview3-crash-rename-autogenerated-events

I’ve noticed that prior the crash, there where simingly invisible characters ‘deleted’ while hitting delete. Eg

  1. “| - 05 - Some Event”
  2. “|- 05 - Some Event”
  3. “| 05 - Some Event”
  4. “|05 - Some Event”
  5. “|5 - Some Event”
  6. “| - Some Event”
  7. “| - Some Event” (nothing “happened” here)
  8. “|- Some Event”
  9. “| Some Event”
  10. “|Some Event”

I’m not sure though, if it was at 7 or maybe 3 when ‘hothing’ happened. Additionally, while deleting, some little UI relayout happened (wiggled left and right) but I didn’t spot, what has actually happened.

Next time I’ll manage an import, I’m sure :smiley:

The interpretation is correct. The underlying reasoning is rooted in the way things will work once the synchronization feature is enabled. In particular, spreading a library over multiple disks will be supported through synchronization of multiple instances of the same library as opposed to having a central library instance that references images on separate drives.

This has the advantage that each drive can be taken individually, with the whole library still being available - just that only a part of the images can be accessed at full resolution. Currently, explaining this situation from within the application is difficult and wouldn’t really make sense, so indeed it’s not very clear why this error occurs, but we will improve that once synchronization has landed. We also already talked about adding a “help” button that links to the documentation to that dialog.

This is currently just a UI stub, which will be replaced by something that actually works in the next version (#451).

I’ve added this pattern to the list of common prefixes, so that it should work as expected in the next version.

I could observe the same behavior, caused by a concurrent update of the tree item - fixed now.

This is interesting, from the log it almost looks like it shut down normally, but it didn’t. The fact that there is no sign of an assertion failure or access violation in the log points to a stack overflow or some other error condition that is currently not handled. Did a Windows crash report dialog appear by any chance? At which point did the application exit, when opening the library creation dialog, while it was open, or after hitting “create library”?

I’ll have to take a deeper look at this, tracked as #452.

I really hope that we’ll finally get to the point where it’s possible to get images into the application :wink: . This is almost the same as with @leonid, who struggled for quite a while to get his photos imported from an SD card, while @Meikel or me never had an issue, although that was for totally different reasons.

After library creation. I looked at the application to figur out if the library was created / switched. I think the old library name was still displayed when it closed without any additional crash dialog.

To be more exact, as I still didn’t get that: The message how it was displayed was correct? Because: I was importing from drive d: . How can it be a solution to use drive d: ? Anyway, I didn’t look at the help article yet. I’ll find that via in app menu> help or where? (I’m not at the laptop atm)

Ohhh, I missed that. The drive letters are interchanged! I’ll fix that right away.

Next time import:

Crash when selecting import folders.

  1. Went for file system, went to my folders
  2. Select a couple, hit import multiple sub-folders, auto create
  3. Closed that dialog, as I expected that import button to be subject only to the selection [UX question]
  4. Done 2 again, but without auto create, then selected a couple in the import dialog by hand.
    Note: I also tried to shift+click select a couple of folders in the import screen, but that didn’t seem to have an effect.
  5. Crash when checkboxing one folder

Did that again, imported a couple of folders (directly after app start without too many side steps): It imported photos!

Then I went for exploring the app while the caches were building up. At some point there was a crash. The steps to reproduce this would be quite plentyfully though.